I switched my dev. environnement at work from MAMP to Zend Server Community Edition a while ago but was disappointed that my Mac Book could not migrate because of a MySql error. Every time I would try to run the server, I would get the following error:

1
ERROR! MySQL PID file could not be found!

Googling this error, all kinds of solutions came up: privileges on the files, misconfiguration issues, installation problems…
It seems to be a generic message. After trying to understand what might have happened to the missing PID file, I tried re-installations and all the common MySql on Mac OS X tips I could find on Google. No luck. At least, MAMP worked.

Eventually, the same error occured on alheim‘s computer. He eventually found a solution which worked for him (SnowLeopard running on Mac Book Pro) for my own laptop as well (Snow Leopard on a black MacBook).

So here are the steps we took:

1
2
3
4
5
cd /usr/local/zend/mysql
sudo scripts/mysql_install_db
sudo chown -R zend:wheel data
cd ..
sudo bin/zendctl.sh start-mysql

Hopefully, you’ll get a “SUCCCESS” message, too. Thanks to Alheim for the tip.

Filed under: Computing, Mac OS X

Tagged with: , , ,

Liked this page?

Tweet it

Subscribe to the RSS feed or sign up for the newsletter now.

Posts related to Zend Server Community Edition for Mac OS X – MySQL problem

11 Comments to "Zend Server Community Edition for Mac OS X – MySQL problem"

  1. Trackback on samantha on February 28, 2010 at 8:05 am

    New blog post: Zend Server Community Edition for Mac OS X – MySQL problem:
    I switched my dev. environnement at wo… http://bit.ly/bi9ODQ

  2. Comment by greg on May 28, 2010 at 6:53 pm Reply

    Hi,
    I have exactly the same problem and environment (MacBook PRO with alread MAMP installed) and i can’t solve the problem

    ERROR! MySQL PID file could not be found!

    I have tried your solution but no way…
    EDIT > ARRRRRRRRRRRRGGGGGHHHHH i have just forgot one line now it works !

    Thank you so much

    greg

    • Comment by shalfon on May 28, 2010 at 10:12 pm Reply

      Glad this post was of help. It was a nightmarish problem for me for a while, too

  3. Comment by Mathias on August 4, 2010 at 12:20 pm Reply

    Thanks dude! Helped a lot.

  4. […] already wrote about solving the mysql error which prevents the server from starting. Researching this again, I found more information about it. […]

  5. Comment by Siavashrahbaran on August 6, 2011 at 11:14 pm Reply

    Hi , I have same problem in win 7 can you tell me how can fix that in windows , considering I used Wampserver

    Thanks

  6. Comment by Ausnahmezustand.Mac on December 3, 2011 at 9:45 am Reply

    GREAT!! This is the solution…
    Two days i worked for the problem on new mbp with Lion…
    …install zend… search answers with google… testing… uninstall zend… and so on
    After my last uninstall of zend, removing the user/group zend, and going to clean start point.
    Clean install of zend, login as root for tuning the /etc/profiles with the PATH, and taking your steps, the MySQL works… i love it!!
    THANKS From GERMANY

  7. Comment by Steven on January 31, 2012 at 4:19 pm Reply

    Thank You!

    I’ve been chasing red herrings for days – like Googling for “zend server ce myphpadmin mysql default username password”. After trying to connect with PHP & googling for “Lost connection to MySQL server at ‘reading initial communication packet’, system error: 61”, I came upon your other post http://www.worldgoneweb.com/2011/zend-server-community-edition-for-mac-os-x-–-mysql-permissions/, which brought me here.

    FYI. I had similar connection issues with Zend Server CE on my WinXP. The problem there was starting Zend Server CE did not start the MySQL service. So silly questions like “Is MySQL running” aren’t so silly after all 🙂

    Thank You (squared)!

  8. Comment by KevOne on April 12, 2012 at 7:20 pm Reply

    A great thanks from France !!!!!!!!

    I was a young developer working on a very important project for my degree when my MySQL crashed out ! 🙁
    None of the solutions found on google resolved my problem … and i was totally depressed.

    Now, i’m still a young developer … BUT MY SYSTEM WORKS 🙂 😉

    Thanks again

    • Comment by shalfon on April 12, 2012 at 9:19 pm Reply

      Congratulations, and best wishes for your degree. I’ve been working for five years already but still think of myself as a young developer as I’m always learning. Great to know I can pass on some of the things I discovered along the way.

  9. Comment by Etsuko on August 24, 2012 at 7:29 pm Reply

    Оh my goodness! Awеѕome article dude!

    Thank yοu so muсh, Howeνer I am encountering
    pгοblеms ωith your RSS. I ԁon’t understand why I can’t join it.
    Is there аnуonе еlse having the same RSS issues?

    Anyone that knоws the solution can you kindly rеѕρonԁ?
    Thаnks!!

Name (required)

Email (required)

Website

Leave a Reply

  • About Me


    photo of Samantha Halfon Samantha Halfon
    Software Engineer
    blueKiwi software
    Paris, France
    I enjoy playing with my computer(s), listening to Bob Dylan (and related artists) and watching movies (especially if they were directed by Martin Scorsese or John Cassavetes). Sometimes, I play a little guitar... If not doing any of the above, I am either riding a small red bike around Paris, or, making videos. About my videomaking please check out World Wide Angle and its blog.